安装CentOS PHP后Apache启动失败,如何解决?

更新于
2026-09-29 06:11:43
2阅读来源:SEO资讯
  • 内容介绍
  • 文章标签
  • 相关推荐

本文共计288个文字,预计阅读时间需要2分钟。

安装CentOS PHP后Apache启动失败,如何解决?

CentOS安装PHP后Apache无法启动的解决方法:

1.编辑文件/etc/sysconfig/selinux,添加SELINUX=disabled;

2.不关闭SELINUX即可。

操作环境:CentOS 6.8系统、PHP 5版本,Dell G3电脑,CentOS安装PHP后Apache无法启动。

centos安装php后apache不能启动的解决办法:1、编辑“/etc/sysconfig/selinux”,添加“SELINUX=disabled”;2、不关闭SELINUX即可。

本文操作环境:centOS6.8系统、PHP5版,DELL G3电脑

centos安装php后apache不能启动的解决办法:

安装CentOS PHP后Apache启动失败,如何解决?

在安装完成PHP后, 重新启动apache报如下错误

原因是Linux有一个SELinux保护模式引起的。

Syntax error on line 268 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp5.so into server: /usr/local/apache2/modules/libphp5.so: cannot restore segment prot after reloc: Permission denied

解决办法

1.编辑/etc/sysconfig/selinux,找到:

# This file controls the state of SELinux on the system. # SELINUX= can take one of these three values: # enforcing - SELinux security policy is enforced. # permissive - SELinux prints warnings instead of enforcing. # disabled - SELinux is fully disabled. SELINUX=enforcing

如果SELINUX已经是 SELINUX=disabled,那么就不用改了,否则就把SELINUX=enforcing 注释掉,新加一行:

SELINUX=disabled

保存,退出。

2.不关闭SELINUX的方法:

# setenforce 0 # chcon -c -v -R -u system_u -r object_r -t textrel_shlib_t /usr/local/apache/modules/libphp5.so # service httpd restart # setenforce 1

本文共计288个文字,预计阅读时间需要2分钟。

安装CentOS PHP后Apache启动失败,如何解决?

CentOS安装PHP后Apache无法启动的解决方法:

1.编辑文件/etc/sysconfig/selinux,添加SELINUX=disabled;

2.不关闭SELINUX即可。

操作环境:CentOS 6.8系统、PHP 5版本,Dell G3电脑,CentOS安装PHP后Apache无法启动。

centos安装php后apache不能启动的解决办法:1、编辑“/etc/sysconfig/selinux”,添加“SELINUX=disabled”;2、不关闭SELINUX即可。

本文操作环境:centOS6.8系统、PHP5版,DELL G3电脑

centos安装php后apache不能启动的解决办法:

安装CentOS PHP后Apache启动失败,如何解决?

在安装完成PHP后, 重新启动apache报如下错误

原因是Linux有一个SELinux保护模式引起的。

Syntax error on line 268 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp5.so into server: /usr/local/apache2/modules/libphp5.so: cannot restore segment prot after reloc: Permission denied

解决办法

1.编辑/etc/sysconfig/selinux,找到:

# This file controls the state of SELinux on the system. # SELINUX= can take one of these three values: # enforcing - SELinux security policy is enforced. # permissive - SELinux prints warnings instead of enforcing. # disabled - SELinux is fully disabled. SELINUX=enforcing

如果SELINUX已经是 SELINUX=disabled,那么就不用改了,否则就把SELINUX=enforcing 注释掉,新加一行:

SELINUX=disabled

保存,退出。

2.不关闭SELINUX的方法:

# setenforce 0 # chcon -c -v -R -u system_u -r object_r -t textrel_shlib_t /usr/local/apache/modules/libphp5.so # service httpd restart # setenforce 1